Up to cover page | Back to Conformance | On to ECMAScript

CGM Open specification - WebCGM 2.0 - References


Contents

8. References

This section's subsections are normative or informative, as individually labeled.

8.1 Normative references

This subsection is normative.

ISO/IEC 8632:1999(E)
Information technology - Computer graphics - Metafile for the storage and transfer of picture description information
- Part 1: Functional description
- Part 3: Binary encoding
- Part 4: Clear text encoding

Available at the ISO page of Publicly Available Standards. CGM:1999 was reaffirmed by ISO, without changes, at its 5-year review in 2004. The WebCGM profile is defined by reference to the ISO standard.

RFC 3986
Uniform Resource Identifiers (URI): Generic Syntax, available at http://www.ietf.org/rfc/rfc3986.txt .
RFC 3987
Internationalized Resource Identifiers (IRIs), available at http://www.ietf.org/rfc/rfc3987.txt .
RFC 1951
Deutsch, P., "DEFLATE Compressed Data Format Specification version 1.3", RFC1951, Aladdin Enterprises, May 1996,
URL: http://www.w3.org/Graphics/PNG/RFC-1951
ISO/IEC 10646-1:1993, AM2:1996
Information technology - Universal multiple-octet coded character set (UCS)
- Part 1: Architecture and Basic Multilingual Plane
AMENDMENT 2: UCS Transformation Format 8 (UTF-8)
REC-png
PNG (Portable Network Graphics) Specification, Version 1.0, URL:
http://www.w3.org/TR/REC-png-multi
RFC 2119
IETF RFC 2119: Key words for use in RFCs to Indicate Requirement Levels, S. Bradner, March 1997. Available at http://www.ietf.org/rfc/rfc2119.txt .
XML 1.0
XML 1.0, third edition, http://www.w3.org/TR/2004/REC-xml-20040204/ .
Namespaces in XML
http://www.w3.org/TR/REC-xml-names

8.2 Informative references

This subsection is informative (non-normative).

SVG 1.1
http://www.w3.org/TR/SVG11/
DOM Level 3 Core
Document Object Model (DOM) Level 3 Core Specification, available at http://www.w3.org/TR/2004/REC-DOM-Level-3-Core-20040407/.
DOM Level 3 Events
Document Object Model Level 3 Events Specification, available at http://www.w3.org/TR/2003/NOTE-DOM-Level-3-Events-20031107.
HTML 4.01
HTML 4.01 Specification, available at http://www.w3.org/TR/html401/.
CSS 2.0
http://www.w3.org/TR/CSS2/
Xpointer Framework
http://www.w3.org/TR/2003/REC-xptr-framework-20030325/
Cascading Profiles
Definition and description of how to write a profile based on WebCGM as the starting point, for closely related technical application sectors. At http://www.cgmopen.org/technical/cascading-profiles.html
WebCGM 2.0 Requirements
The requirements used to define the new functionality for WebCGM 2.0. At http://www.oasis-open.org/committees/download.php/14243/WebCGM_20_Requirements.html
SpecGL 1.0
The W3C QA Framework: Specification Guidelines, has guided the inclusion of the normative Conformance clause, and other conformance-related details of WebCGM. At http://www.w3.org/TR/qaframe-spec/.

8.3 Document sources and Registration Authority

This subsection is informative (non-normative).

Copies of the ISO standards may be obtained from ISO:

ISO Central Secretariat
1, rue de Varembe
Case postale 56
CH-1211 Geneve 20
Switzerland

For the purpose of this Recommendation and according to the rules for the designation and operation of registration authorities in the ISO/IEC Directives, the ISO and IEC Councils have designated the following as the registration authority:

National Imagery and Mapping Agency (NIMA)
(Joint Interoperability Test Command)
The Registration Authority for Graphical Items
Building 57305
Fort Huachuca
Arizona
85613-7020
USA

For more information on the CGM standard itself, the CGM Open Web site has both bibliographic references, and short articles on CGM topics:

CGM Open
http://www.cgmopen.org/

The following World Wide Web sites have more information on CGM:

ISO/JTC1/SC24
http://www.cwi.nl/JTC1SC24/
W3C WebCGM Overview
http://www.w3.org/Graphics/WebCGM


Back to top of chapter